iOS 8 Compatibility

We are all excited about the new iOS 8 software for iPhone! Right now, you may experience some issues with the SkyBell app if you have just downloaded this software update.

Because we did not have access to the platform before its release, we were unable to update the SkyBell app along with iOS 8 release and we apologize for this inconvenience. Now that the software is available, our app team is hard at work to update iPhone app software so that your SkyBell app will soon work perfectly with iOS 8.

Have more questions? Submit a request
Powered by Zendesk